标签:CocoaPods

移动开发

Swift iOS : 使用CocoaPods管理依赖

12月07日

iOS 程序提供依赖管理的工具,它的名字叫做:CocoaPods。开发一个可用的系统,再怎么小也需要依赖第三方库,比如大家常常采用Alamofire这个第三方库来访问网络。 以我...
移动开发

CocoaPods 安装错误解决

12月04日

最近在安装CocoaPods ,各种坑,参考网上的文章结果一大堆的错误,于是乎在这个浩瀚的知识的海洋世界遨游了半天,黄天不苦心人啊,终于是安装成功了。接下来,把我遇到的问题及解决方...
移动开发

模块代码大小分析

11月27日

背景 app 体积越来越大,App Store 还有 100M 不能使用流量下载的限制。无论是领导或者产品经理,都希望包尽量小,而功能尽量多。 iOS 打包生成的可执行文件 ipa...
CocoaPods设置target支持的swift版本
移动开发

CocoaPods设置target支持的swift版本

11月27日

上一篇文章说道在 Swift4.0 中如何引用 3.0 版本的第三方库,详见这篇文章。但是如果 Pods 中有很多第三方库都只支持 3.0 ,一个一个修改恐怕是要累死。而且每次执...
移动开发

CocoaPods的更新

11月23日

换了新公司,电脑还没到位,就先用自己的老电脑了。在使用CocoaPods的时候提示[!] The `master` repo requires CocoaPods 1.0.0 &#...
iOS组件化实践(基于CocoaPods)
移动开发

iOS组件化实践(基于CocoaPods)

11月20日

做iOS开发的同学对这张图片再熟悉不过了,在使用第三库的时候,cocoapods确实给我们带来了极大的方便。那么,我们如何制作自己的pod呢?下面是之前的实践笔记 参考资料...
CocoaPods工程使用插件App Extension
移动开发

CocoaPods工程使用插件App Extension

11月14日

为APP添加的Extension的方法很简单,在工程下new一个target,选择相应功能的Extension即可。Xcode会为我们自动创建好入口文件,我们只要在相应函数里填上响...
移动开发

CocoaPod的使用至导入依赖库

11月13日

安装CocoaPods如下步骤: 一、首先查看ruby版本 1. 查看当前ruby版本的命令:ruby -v(Mac自带ruby环境,所以不需要进行相关安装的操作) 若是需要安装r...

专业 x 专注 x 聚合 x 分享 CC BY-NC-SA 4.0

使用声明 | 英豪名录